Benutzer-Werkzeuge

Webseiten-Werkzeuge


ubuntu

Ubuntu allgemein

Bei der Installation von Benno MailArchiv werden einige Pakete aus den „universe“ Repositories benötigt. Diese sind bei unter Umständen bei der Default-Installation von Ubuntu Server nicht konfiguriert und müssen vor der Installation von Benno MailArchiv aktiviert werden.

Ubuntu 18.04

Bei Installation von Ubuntu 18.04. ist nichts zu beachten. Die Pakete können ohne weitere Konfigurationsanpassungen installiert werden.

Ubuntu 16.04

Bei der Installation auf einem Ubuntu 16.04 System sind einige Vorarbeiten notwendig.

Bevor das Paket benno-web installiert werden kann, müssen der Apache Webserver und PHP-Pakete installiert werden.

apt-get install apache2 libapache2-mod-php7.0 php7.0-sqlite3 php7.0-curl php-mbstring

Danach werden das Prefork-Modul sowie das PHP7 Modul aktiviert.

a2enmod php7.0
a2dismod mpm_event
a2enmod mpm_prefork

Jetzt kann die Installation von Benno MailArchiv durchgeführt werden.

apt-get install benno-archive benno-rest benno-web

Ubuntu 12.04

Die aktuellen Versionen von Benno MailArchiv benötigen eine aktuellere Version von OpenJDK. Beim Upgrade auf eine aktuelle Version von Benno MailArchiv muss daher zusätzlich ein PKK-Repository eingebunden werden. Die Beschreibung findet sich u.a. im Unbuntu Handbuch.

ubuntu.txt · Zuletzt geändert: 2018/10/30 16:24 von lwsystems